Fujitsu E780 Tastatur tauschen

  • direkt über der Tastatur ist eine schmale Leiste (da wo die Symbole zu den LEDs drauf sind), diese schmale Leiste muss mit sanfter Gewalt zuerst ausgeklipst werden
  • Da drunter sind 4 „merkwürdige“ Schrauben, ’nen ganz kleiner Innensechskant oder sowas, die müssen raus. Ein  schmaler Uhrmacherschraubenzieher (Schlitz) geht da auch, wenn man vorsichtig ist.
  • Danach kann man das ganze schwarze Plastikteil, auf dem die Schalter und LEDs sind, ausklipsen. Wenn es vorn lose ist, Display ganz nach hinten klappen und vorsichtig die letzten beiden Klipse hinten unter der Abdeckung für die Scharniere lösen. Achtung, da geht ein Kabel ran, das Teil also nur vorsichtig anheben und nach hinten klappen, das Kabel kann dran bleiben
  • Tastatur vorsichtig von hinten nach vorn anheben (doppelseitiges Klebeband ist da drunter). Wenn die Tastatur einen Touchpoint hat, ist unter der Tastatur noch ein dünnes Kabel, was man vorsichtig aus dem Stecker lösen muss
  • Tastaturkabel oben links abziehen
  • neue Tastatur in umgekehrter Reihenfolge einbauen
Veröffentlicht unter Hardware | Schreib einen Kommentar

HVB und Sicherheit

Die Sicherheit von FinTS basiert darauf das ich beim Einrichten den Hashwert des Schlüssels der Bank mit einem per Post erhaltenen Schlüssel vergleiche,  stimmt dieser überein, bin ich sicher, auch mit dem Server Bank verbunden zu sein. Dann schicke ich den Hashwert meines Schlüssels an die Bank und lasse den Freischalten, so das die Bank auch sicher sein kann, das über FinTS ausgelöste Aufträge von mir kommen. So weit so gut, so funktioniert gegenseitige Authentifizierung.

Warum aber meinst die HVB diese Woche, mir über die Bankparameterdaten einen neuen Schlüssel unterschieben zu müssen, ohne das vorher eine Information auf einem anderen Kommunikationsweg gab ? Warum gibt es dazu weder einen Hinweis auf den Webseiten, noch eine persönliche Information ? Und warum weiß die Hotline nichts davon, und gibt falsche Auskünfte, bezieht sich nur auf die Freischaltung meines Schlüssels und verweist mich letztendlich an den Softwarehersteller, der dieses Problem nun wirklich nicht lösen kann ?

Es kommt noch besser: Im FinTS Standard steht drin, das die Verifikation der neuen Bankschlüssel „grundsätzlich optional“ ist.  Wer denkt sich denn sowas aus ?

Veröffentlicht unter $%&/()"§ | Schreib einen Kommentar

„Premium“-Support bei Starmoney

Beim Kauf von StarMoney kann man sich entscheiden, ob man telefonischen Support kauft und dann über eine normale Festnetznummer erhält, oder es aber eben nicht kauft und dann nur eine teure 0900er Nummer bekommt.

Ich habe mich für die erste Variante entschieden und hatte auch schon jetzt 2 Mal ein Problem, so das ich den Support angerufen habe.

Was ich gar nicht gut finde, ist das man nach dem üblichen Telefoncomputer erst einmal in einer laaaangen Warteschleife landet. Beim ersten Anruf am 14.10. hatte ich etwa eine Stunde Warteschleife, heute (13.12.)  bin ich auch im Moment bei über 40 Minuten und höre immernoch Dudelmusik und Entschuldigungen vom Band.

Dafür, das man den Support (in der einen oder anderen Weise) extra zahlen muss,finde ich das gar nicht gut.

 

Veröffentlicht unter $%&/()"§, Software, Windows | Schreib einen Kommentar

Gratuitous ARP mit Intel NIC

Fehlersuche nervt, vor allem, wenn man für den Fehler nix kann. Vorgestern leuchtete irgendwann im Nagios ein Server rot, hohe Paketverluste bei Ping, Dienste kaum noch erreichbar. Komischerweise war der Server über eine 2. Netzwerkschnittstelle perfekt erreichbar und alle Dienste ok. Also musst es irgendwas mit der öffentlichen Netzwerkschnittstelle sein. Ein Blick auf den Switch offenbarte, das einem anderer Server am gleichen Switch die gleiche MAC zugeordnet war. Sollte so eigentlich nicht sein. Also auf den anderen Server geschaut. Keinerlei Einträge mit der MAC des ersten Servers bei ip addr. tcpdump lieferte auch nichts verdächtiges. Komisch.

An den Netzwerkanschluss des 2. Servers einen Hub, da dann ein Notebook mit Wireshark dran. Noch nicht mit dem Netzport vom eigentlichen Switch verbunden. Wireshark gibt gratuitous ARP Pakete aus, mit der MAC & IP des ersten Servers. WTF. ifconfig eth0 down auf der Kiste. Immernoch gratuitous ARP Pakete. Reboot, sicherheitshalber mal 2 Minuten stromlos dazwischen, damit es die Netzwerkkarte auch resetet… Sobald das BIOS die Netzwerkkarte initialisiert, noch bevor überhaupt das Betriebssystem geladen ist, gratuitous ARP Pakete. Woher ? Wieso ? Andere Netzwerkbuchse von dem Ding: sauber (aber langsam, der hat nur eine Gigabit). Blöd.

Andere, baugleiche Kiste (Fujitsu Siemens RX 100)  stand noch als Reserve im Schrank, Platte umgebaut, gebootet. Gratuitous ARP Pakete, diesmal mit anderer MAC & IP, aber wieder nicht seine, sondern von einem anderen Server. Ansonsten wie vorher, Pakete auch ohne Betriebssystem. Also Serienfehler in den Netzwerkmodulen (onboard, Intel) ? Zusätzliche Netzwerkkarte eingebaut, die genommen: Alles sauber. Problem gelöst. 2 Tage verschenkte Zeit wegen irgendeines Serienfehlers in dem Intel Netzwerk Chip. Oder dessen Firmware, keine Ahnung. Komischerweise lief der die letzten ca. 10 Jahre in der Kiste problemlos.

Veröffentlicht unter $%&/()"§, Hardware, Software | Schreib einen Kommentar

Synology und Chaosradio

Der Synology DSM Download-Manager hat ja eine nette Funktion, RSS Feeds automatisch zu laden. Leider lädt der nur <link>-Tags aus dem RSS, beim Chaosradio steht die MP3 aber in einem enclosure-Tag. Folgendes Mini-Script, was direkt im Web-Verzeichnis der Synology gelandet ist, behebt das:

<?php
if ($_SERVER['REMOTE_ADDR'] != "127.0.0.1") exit;
$d = file_get_contents($_GET['u']);
$d = preg_replace("/<link>(.*?)<\/link>/","",$d);
$d = preg_replace("/<enclosure.*?url=\"(.*?)\".*?>/","<link>\\1</link>",$d);
Header("Content-Type: application/rss+xml");
echo $d;

Eingabe im DSM Download-Manager dann mit http://localhost/script.php?u=http://url_des_feeds

Veröffentlicht unter Software, Websoftware | 5 Kommentare

openSuSE und iSCSI boot….

So langsam mag ich openSuSE nicht mehr… selbiges auf einem Server ohne Platte (die im SAN ist) zu installieren, artet da richtig in Arbeit aus.

  • Bei Installation von (Remote-) DVD gibt es keine Möglichkeit, irgendwo Netzwerkparameter vor der Installation zu setzen, so das der erstmal ohne Platte aussteigt und iSCSI Platten nicht mounten kann. Wenn man als Installationsquelle Netzwerk wählt, kann man das zumindest ändern, und hinterher doch wieder auf DVD umschalten.
  • Das GUI zum Verbinden von iSCSI-Targets ist komplett kaputt, der findet zwar im yast die Platten, listet die aber nur als leere Zeilen auf. Verbinden geht gar nicht. Naja, es gibt ja 2. Konsole und iscsiadm…
  • Nach der Basisinstallation stürzt das System vor der weiteren Konfiguration ab, und zwar nach dem Ausführen der Scripte in der initrd meint er, die Platte nicht mehr zu finden. Es findet sich nen Bugreport, das der iscsid kaputt ist, das in 11.2 und 11.4 gefixed wurde, der Fehler aber in 12.1 wieder da ist. Immerhin, wenn man beidseitiges CHAP verwendet, tritt der Fehler nicht auf, weil der iscsid wohl nur ein Problem mit leeren Benutzernamen / Passworten hat.
  • Der Rest der Installation läuft erstmal durch, nach dem Update zeigt yast sogar die iscsi-Targets, verbinden kann er die aber immernoch nicht
  • multipathd stürzt beim Starten mit buffer overflow ab, komischerweise auf der Konsole im Vordergrund mit Debugging gestartet läuft er. In der nächsten Version ist es gefixed, also mal schnell aus den Quellen nachinstallieren…
  • Das man sich dann das Configfile /usr/share/doc/packages/… ziehen muss, um ein Template zu haben, ist auch unschön
  • Viel hässlicher ist aber, das das SuSE udev-Script für kpartx kaputt ist und ein vol_id aufrufen will, was es nicht gibt. Das Script aus den multipath-Sourcen geht, nur kopiert er das unter einem anderen Namen nach /etc/udev, so das man das da auch von Hand ändern muss.Ohne das Script gibts keine Device-Nodes für die Partitionen unter /dev/mapper/
  • Jetzt nur noch dm-multipath der initrd hinzufügen (/etc/sysconfig/kernel) und die neu bauen (mkinitrd)… und die Kiste bootet erst mal gar nicht mehr, weil er das Root-Device nicht findet
  • Also da auch in /boot/grub/menu.lst den Eintrag für das root-Device auf das passende Device-mapper Device ändern

PS: Wollte es zwischenzeitlich schon mit Ubuntu Server versuchen, das ist auch nicht besser, wenn auch anders…. da habe ich keine Möglichkeit gefunden, der initrd zu sagen, das er die Netzwerkparameter entweder statisch setzen soll oder direkt von den Netzwerkkarte (ibft) lesen soll, ohne DHCP tut der wohl gar nicht…

Veröffentlicht unter $%&/()"§, Linux, Software | Verschlagwortet mit , , , | Schreib einen Kommentar

wenn man sich auf die Technik verlässt…

Fritz!Box verschläft Zeitumstellung

…natürlich war der Wecker im Telefon auch betroffen 🙁

Veröffentlicht unter $%&/()"§, Hardware, Software | Schreib einen Kommentar

Oberbürgermeisterwahl Ilmenau

Wahlbündnis Ilmenau

Veröffentlicht unter Ilmenau, Lokal | Schreib einen Kommentar

OpenSuSE 12.1 – kein ssh -X / X11 Forwarding

Bei deaktiviertem IPv6 mag ssh kein X11 Forwarding mehr machen, ohne das man in der sshd_config AddressFamily inet ergänzt…

Veröffentlicht unter Linux, Software | 2 Kommentare

NFS4 und userID Mapping

…funktioniert wohl nicht so, wie ich mir das gedacht habe. Ich hatte eigentlich gedacht, das gleiche Benutzernamen auf Server und Client ausreichen, die uids aber verschieden sein können. Scheint aber nicht zu funktionieren, er zeigt zwar Name und sogar userid auf dem Client richtig an, aber der Benutzer kann dort trotzdem nicht schreiben: „Permission denied“. Das kommt aber schon so vom NFS Server, dem der Client offensichtlich zum Zugriff / Authentifizierung die lokale uid schickt, und ausgerechnet diese wohl nicht über den identd auf die des Servers mapped.

…gerade nachgelesen, liegt wohl an dem AUTH_SYS von RPC… und geht nur mit Kerberos Authentifizierung. 🙁

 

Veröffentlicht unter $%&/()"§, Linux, Software | Schreib einen Kommentar